WEB UI to manage Internal/External scode translations:


The negative "result" codes  in the customer's CDRs section can be interpreted using the following table:


IDDescriptionHint
-1External Translator Rejected The CallCheck configured external translator script. Contact support team.
-2Body-less INVITEOld code for INVITE without SDP. Contact support team.
-3Account ExpiredCheck Lifetime setting on Account.
-4Connection Capacity ExceededCheck Capacity setting on Vendor Connection.
-5Malformed SDPCheck SDP in incoming INVITE.
-6Unsupported Content-TypeCheck SDP in incoming INVITE.
-7Unacceptable CodecCheck Preferred Codec and Use Preferred Codec Only on Account.
-8Invalid CLD Translation Rule In The Authentication RuleCheck CLD Translation Rule syntax on Authentication Rule of an Account.
-9Invalid CLI Translation Rule In The Authentication RuleCheck CLI Translation Rule syntax on Authentication Rule of an Account.
-10Invalid CLD Translation Rule In The AccountCheck CLD Translation Rule syntax on Account.
-11Invalid CLI Translation Rule In The AccountCheck CLI Translation Rule syntax on Account.
-12Cannot Find The Session To Bind ToThe session was not found in b2bua. Contact support team.
-13Invalid CLI Translation Rule In The DIDCheck CLI Translation Rule syntax on DID.
-14No Rate Found In TariffCheck Tariff Rates of Account.
-15Call Loop DetectedCheck Disallow Loops on Account.
-16Too Many SessionsCheck Max Sessions on Environment.
-17Account Is In UseCheck Max Sessions on Account.
-18Call Per Second (CPS) Limit On Account ExceededCheck Max Calls Per Second on Account.
-19Call Per Second (CPS) System Limit ExceededCheck Max CPS on Account.
-20Insufficient BalanceCheck Balance on Account/Customer.
-21Destination Is ForbiddenCheck Destination Set Route Forbidden flag.
-22No Rate Found In Customer's TariffCheck Tariff Rates of Customer.
-23Loss ProtectionCheck Loss Protection on Tariff.
-24Address Is IncompleteCheck Min/Max Length for the prefix in Destinations.
-25No Routes FoundCheck Route in Destination Set.
-26Call Per Second (CPS) Limit On Connection ExceededCheck Max CPS on Vendor Connection.
-27Invalid Asserted ID Translation Rule In The AccountCheck Identity Translation Rule syntax on Account.
-28CLD is in the Do Not Call ListCheck DNC List and DNCL Lookup setting on Account/Customer.
-29Invalid CLD Translation Rule In The DIDCheck CLD Translation Rule syntax on DID.
-30Call has been canceled by calling partyCaller aborted the call.
-31Call Per Second (CPS) Limit On Customer ExceededCheck Max Calls Per Second on Customer.
-32Too Many Sessions For CustomerCheck Max Sessions on Customer.
-33Call Per Second (CPS) Limit On Auth Rule ExceededCheck Max Calls Per Second on Account Authentication Rule.
-34Too Many Sessions For Auth RuleCheck Max Sessions on Account Authentication Rule.
-35Invalid CLI Translation Rule In Post-Auth RuleCheck CLI Translation Rule syntax on Account Post Auth Rule.
-36Invalid CLD Translation Rule In Post-Auth RuleCheck CLD Translation Rule syntax on Account Post Auth Rule.
-37CLI is in the Do Not Call ListCheck CLI DNC List and DNCL Lookup setting on Account/Customer.
-38Too Many Sessions OverallSystem Max Sessions limit exceeded. Contact support team.
-39Call Per Second (CPS) Overall Limit ExceededSystem Max Calls Per Second limit exceeded. Contact support team.
-40Anonymity DisallowedCheck Block Incoming AC on Account.
-41STIR/SHAKEN verification failedBad Identity in incoming INVITE, check Verification Connector settings in Stir-Shaken.
-42Internal Server ErrorCheck RTPProxy status. Contact support team.
-43Media Relay ErrorCheck RTPProxy and SMG status. Contact support team.
-44STIR/SHAKEN Identity RequiredNo Identity in incoming INVITE, check Verification Connector settings in Stir-Shaken.
-45STIR/SHAKEN Authentication failedCheck Authentication Connector settings in Stir-Shaken and STIR/SHAKEN settings in Routing Group.
-46Blocked by On Billing Failure ActionAccount balance was insufficient to charge Service Plan or DID fees. Top up account.
-47External Translator Outbound Rejected The CallCheck configured external translator outbound script. Contact support team.
-48DND EnabledUnset DND Enabled setting on Account Advanced Parameters.
-49CLI Is In BlocklistRemove the CLI from the Blocked Numbers. Contact support team.


For inbound calls there will be the following SIP error codes:


400, 'Bad Request - Malformed SDP'
400, 'Bad Request - Unsupported Content-Type'
403, 'Account Expired'
403, 'Account in Use %d' % self.i_account
403, 'Auth Failed (1)'
403, 'Auth Failed (2)'
403, 'Call Loop Detected'
403, 'Call rate too high for account %d' % self.i_account
403, 'Call rate too high'
403, 'Forbidden Destination %s' % prefix
403, 'Insufficient Balance %d' % self.i_account
403, 'Invalid CLD translation (1)'
403, 'Invalid CLD translation (3)'
403, 'Invalid CLI translation (2)'
403, 'Invalid CLI translation (4)'
403, 'Invalid CLI translation (5)'
403, 'Invalid P-Asserted-Id translation'
403, 'Loss to Destination %s Exceeds Max Loss' % prefix
403, 'No Rates Found for Account %d' % self.i_account
403, 'No Rates Found for Customer %d' % i_customer
403, 'Too many active calls'
403, 'Loss Protection'
480, 'DND Enabled'
484, 'Address Incomplete'
488, 'Not Acceptable Here'
500, 'Body-less INVITE is not supported'
500, 'Cannot Bind to the Requested Session'
500, 'Internal Server Error (1)'
500, 'Internal Server Error (2)'
500, 'Internal Server Error'
500, 'No Routes For the Call'
503, 'Call rate too high per connection'
503, 'Service Unavailable (FIXME1)'
503, 'Service Unavailable (FIXME2)'
503, 'Service Unavailable'
603, 'CLI In Blocklist'

Once the customer sends the call, and after the first invite b2bua generate the following error:

500 Internal Server Error
and the call is rejected, most likely that's because the customer has made changes to the routing group of an account (assigned another routing group or so) when there was live traffic running.

As a result, the cache wasn't able to re-read immediately, it usually took up to 1 minute, or so after the first call attempt.


Please, do not confuse this error to any other 500 one:

Server internal error, which could be generated because of different reasons and in different periods of time.


TROUBLESHOOTING:


-4 "Connection Capacity Exceeded" and -16 "Too Many Sessions" (reached env CC limit) codes return 503 Service Unavailable SIP code.


"403 Auth Failed (1)" error is returned by b2bua when the "Trust CLI" option of the account is disabled and CLI doesn't match VoIP login during DIGEST authentication only

"403 Auth Failed (1)" error is returned by b2bua when the account authenticated for the call is BLOCKED. Starting from 5.2 the same error is returned for the case Customer that owns account authenticated for the call is BLOCKED.

Note: no CDRs are written for the calls that are dropped on blocked Account/Customer setup.

"403 Auth Failed (2)" error is returned when VoIP password is incorrect during DIGEST authentication only.


488 Not Acceptable Here

Account codec is not compatible with caller party codec.

Solution: to disable "Use Pref. Codec Only " in account parameters or reconfigure it according to the codec used.